Alert
Error Code 500 on InvoiceQueryRS
Cause
This occurs when the invoice and payment were deleted from QuickBooks or it was recreated within QuickBooks.
Resolution
To resolve this, if the payment entry in FieldEdge is locked, the Invoice Number would need to be adjusted (for example change Invoice i1000 to i1000A) and then you would need to resave the Work Order. At that time the alert can be retried and it should sync to QuickBooks.
If any duplicate invoices reflect within QuickBooks at this point, the FieldEdge User would want to ensure the invoice with the new number is the one that is NOT touched, but any other invoices for this record can be removed within the accounting system.
If the payment entry in FieldEdge is unlocked but QuickBooks shows this as paid, then remove the unlocked payment(s) from FieldEdge and resave the Work Order before retrying the alert. From there, un-apply and reapply the payment within the accounting system.
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