(Alert) 400 Message: BadRequest. Details: Invalid Reference Id : Names element id xxxx not found

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Alert

400 Message: BadRequest. Details: Invalid Reference Id : Names element id xxxx not found

Cause

This alert appears from a work order but is typically directly related to a customer. When you see this alert appear, it is usually accompanied by this alert related to a specific customer.

"Something you're trying to use has been made inactive. Check the fields with accounts, customers, items, vendors or employees."

In our experience, we have found this happens when a customer has been desynced from QB Online. The following resolution can be attempted to repair that connection.

Resolution

  1. Create a new customer in FieldEdge and send it to QB Online.
    • We recommend creating this customer with the same name as the issue customer's name but adding a "1" at the end.
      • Example: If the customer's name was "John Smith," the new customer would be called "John Smith1."
  2. Once the customer has been sent to QB Online; merge the old customer into the new customer by making the old customer's name match the new customer in QB Online.
  3. After you have merged the customers, you'll then merge the customers in FieldEdge.
    • Go to Settings, select Merge Customer, then merge the old customer into the new customer.
      • Before merging in FieldEdge, we recommend taking a screenshot of both customer settings and notes. Merging is a form of deletion and data can be lost.
  4. Finally, look up the merged customer and verify all the information is correct. After you have confirmed the information, click Retry on your alerts and clear them.
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