Alert
400 Message: BadRequest. Details: Transactions with inventory (QOH) products can't be dated earlier than the inventory start date for the product (QBO).
Cause
This is caused when the Start Date field for an item within QuickBooks Online is listed for a date that is after the Transaction Date of the invoice it is being added to. The Start Date is a field that is tracked only by QuickBooks Online for inventory items. It details when you started the item overall, this will usually default to the day the item was created.
Resolution
In QuickBooks Online, you will need to head into the Item page and update the Start Date field to a date before the Transaction Date of the invoice, or update the Transaction Date of the invoice in FieldEdge to be after the Start Date of the item(s). Once either workflow is completed, you can then resave the work order and retry the alert.
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